System Requirements

System Requirements

FormulaBoost runs on Windows and Excel.

Specifically:

  • Image placeholder
    Windows Vista Service Pack 2 or newer (including, 7, 8, 8.1 and Windows 10)
  • Image placeholder
    Microsoft Excel 2007
  • Image placeholder
    Microsoft Excel 2010
  • Image placeholder
    Microsoft Excel 2013
  • Image placeholder
    Microsoft Excel 2016 / 2019 / Office 365
  • Image placeholder
    Microsoft .NET Framework 4.5.2 or later (checked by the installer, download "runtime" version here, if needed)
Summary